Hiren’s BootCD From USB Flash Drive (USB Pen Drive)

 Hiren’s BootCD From USB Flash Drive (USB Pen Drive)

Step 1
Connect USB Pen Drive (1GB or more)

Step 2
Download and Run USB Disk Storage Format USB Disk Storage Format USBFormat.zip (34KB)

Contenido desde el blog: USBFormat
Screenshot

Step 3
Download grubinst_gui Grub 4 Dos grub4dos.zip (179KB) and Run as Administrator

Contenido desde el blog: grub4dos
Screenshot

Step 4
Insert the BootCD (10.3 or newer) in the CD Drive and Copy everything from CD to USB Flash Drive

Step 5
Copy grldr and menu.lst from grub4dos.zip (or from HBCD folder) to the usb drive
Screenshot

Step 6
Test Your USB Drive (read bottom of the page for troubleshoot)

Wowza Media Server: SHOUTCast re-stream

A CONTINUACION: explicacion completa del SHOUTCAST RESTREAM.
Tener en cuenta: WowzaMediaServer-2.2.4_UsersGuide

How to re-stream audio from SHOUTcast/Icecast

This tutorial provides the basic steps for re-streaming a SHOUTcast or Icecast stream through Wowza Media Server® and to configure an application named live to stream to the Adobe® Flash® Player, Apple® iOS devices, and RTSP/RTP-based players.

Note: Microsoft® Silverlight® doesn’t support audio-only Smooth Streaming.

Contents


Tutorial

Troubleshooting

Related Articles

Tutorial


Configuration

This tutorial provides basic steps for setting up an application for live streaming and configuring Application.xml.

  1. Create application folder [install-dir]/applications/live.
  2. Create configuration folder [install-dir]/conf/live and copy [install-dir]/conf/Application.xml to this new folder.
  3. Edit the newly copied Application.xml file and make the following changes (some of these settings may already be present):
    Note: Right-click HERE to download a pre-configured version of Application.xml.
    1. Set the Streams/StreamType property to:
      Code:
      <StreamType>live</StreamType>
    2. Set the HTTPStreamers property to:
      Code:
      <HTTPStreamers>cupertinostreaming,smoothstreaming,sanjosestreaming</HTTPStreamers>
    3. Set the Streams/LiveStreamPacketizers property to:
      Code:
      <LiveStreamPacketizers>cupertinostreamingpacketizer,smoothstreamingpacketizer,sanjosestreamingpacketizer</LiveStreamPacketizers>
    4. Set the RTP/Authentication/PlayMethod to:
      Code:
      <PlayMethod>none</PlayMethod>

Publishing the stream

  1. Use a text editor to create the file [install-dir]/content/radiostation.stream and set the contents of this file to the full HTTP URL of a SHOUTcast or Icecast stream (see URL to connect to SHOUTcast or Icecast).
  2. Using a text editor, edit the [install-dir]/conf/admin.password file and add a username and password that will be used to start and stop publishing of the radio station (below is an example of the file with the username myuser and password mypassword):
    Code:
    # Admin password file (format [username][space][password])
    # username password
    myuser mypassword
  3. Start Wowza Media Server.
  4. Use Stream Manager to start the stream:
    1. Enter the following URL in a web browser :
      URL: http://[wowza-ip-address]:8086/streammanager
    2. in the Security dialog box, enter your admin username and password from above.
    3. In the Stream Manager webpage, click the [start-receiving-stream] link just below the live application folder.
    4. In the Start Receiving Stream dialog box, select the following MediaCaster Type option: shoutcast
    5. In the Stream Name field, enter radiostation.stream.
    6. Click OK.

Playback

Note: In the following examples, [wowza-ip-address] is the IP address or domain name of the server running Wowza Media Server.

Adobe Flash Player (RTMP)

In Wowza Media Server 3.5.0 and later, double-click [install-dir]/examples/SHOUTcast/FlashRTMPPlayer/player.html, enter the information below, and then click theConnect button.

Server: rtmp://[wowza-ip-address]/live
Stream: radiostation.stream

To play the stream from a remote computer, copy the FlashRTMPPlayer folder to a web server, and then connect to: http://<webserver>/FlashRTMPPlayer/player.html.

Note: In Wowza Media Server 3.1.2 and earlier, double-click [install-dir]/examples/SHOUTcast/client/shoutcast.html, enter the information below, and then click the Play button.

Server: rtmp://[wowza-ip-address]/live
Stream: radiostation.stream

To play the stream from a remote computer, copy the client folder to a web server, and then connect to: http://<webserver>/client/shoutcast.html.

Note: If your application will only stream to Flash RTMP clients, see Flash RTMP clients only.

Adobe Flash Player (San Jose/Adobe HDS)

In Wowza Media Server 3.5.0 and later, double-click [install-dir]/examples/LiveVideoStreaming/FlashHTTPPlayer/player.html, enter the information below, and then click the Connect button.

Stream: http://[wowza-ip-address]:1935/live/radiostation.stream/manifest.f4m

To play the stream from a remote computer, copy the FlashHTTPPlayer folder to a web server, and then connect to: http://<webserver>/FlashHTTPPlayer/player.html.

Note: In Wowza Media Server 3.1.2 and earlier, double-click [install-dir]/examples/LiveVideoStreaming/clientOSMF/bin-release/LiveOSMFPlayer.html, enter the information below, and then click the Play button.

Stream: http://[wowza-ip-address]:1935/live/radiostation.stream/manifest.f4m

To play the stream from a remote computer, copy the clientOSMF/bin-release folder to a web server, and then connect to: http://<webserver>/bin-release/LiveOSMFPlayer.html.

Note: The stream can only be played from an OSMF-based Flash player that’s embedded in a webpage.

Apple iOS device (Cupertino/Apple HLS)

Enter the following URL into the Safari® web browser on the device:

URL: http://[wowza-ip-address]:1935/live/radiostation.stream/playlist.m3u8
Note: This stream can also be played using the Safari web browser or QuickTime 10.x on a computer running Mac OS® X Snow Leopard version 10.6 and later.

RTSP/RTP player

Enter the following URL into the RTSP/RTP player:

URL: rtsp://[wowza-ip-address]:1935/live/radiostation.stream

Flash RTMP clients only

(Optional) If your application will only stream to Flash RTMP clients, in [install-dir]/conf/live/Application.xml, you can set the Streams/StreamType property to:

Code:
<StreamType>shoutcast</StreamType>

If you do this, then you won’t need to use StreamManager (see Publishing the stream). The first Flash client that plays the stream will trigger Wowza Media Server to start re-streaming.

Also, in [install-dir]/conf/live/Application.xml, make sure that the Streams/LiveStreamPacketizers property is empty:

Code:
<LiveStreamPacketizers></LiveStreamPacketizers>

Troubleshooting


URL to connect to SHOUTcast or Icecast

The URL that you use to connect to a SHOUTcast or Icecast server is one of the URLS that is contained in a SHOUTcast playlist (.pls) file or Icecast playlist (.m3u) file. Most websites that publish SHOUTcast or Icecast streams have links on their sites that reference these files. To re-stream a SHOUTcast or Icecast stream, you must first download one of the playlist files to your local computer and use one of the links found inside to connect to the published stream.

RTSP/RTP

  • RTSP/RTP streaming is used to stream to Android™ and BlackBerry® mobile devices. Newer Android-based phones also support Adobe Flash Player 10.1 and later, along with RTMP and Adobe HTTP Dynamic Streaming (Adobe HDS).
  • To stream to RTSP/RTP, be sure that UDP ports 0-65535 are open and properly mapped to the server running Wowza Media Server.
  • It’s very important to carefully follow the instructions provided in How to troubleshoot RTSP/RTP playback to properly configure Wowza Media Server for RTSP/RTP streaming.

Common problems with .stream files

Many text editors will append a .txt filename extension to the radiostation.stream filename. This will result in an error message similar to the following:

SDP file missing: c:/program files/wowzamediasystems/wowzamediaserver[version]/content/radiostation.stream

To fix this, go to the [install-dir]/content folder and remove the .txt filename extension from the file.

Property to change AAC packetization method

Wowza Media Server can output AAC audio using the mpeg4-generic and mp4a-latm (3gpp) packetization methods. The default packetization method is mpeg4-generic. To switch to mp4a-latm (3gpp), add the following property to the RTP/Properties container in [install-dir]/[application]/Application.xml (be sure to get the correct<Properties> container, there are several in the Application.xml file):

Code:
<Property>
    <Name>audioPacketizerAAC</Name>
    <Value>com.wowza.wms.rtp.packetizer.RTPPacketizerMPEG4LATM</Value>
</Property>

Wowza – URLs y Notas

Para crear un Stream ( no importa si es VOD (video on demand) o SHOUTcast relay, etc)

mkdir /usr/local/WowzaMediaServer/applicacition/NOMBRE-DEL-STREAM
hacer un cp -Rf de otra app similar ubicada en /usr/local/WowzaMediaServer/conf/, colocar en /usr/local/WowzaMediaServer/conf/.

Stream Manager:
Habilitar streaming.

http://wowza-ip-address:8086/streammanager/

Connectios Counts:

http://wowza-ip-address:8086/connectioncounts

 

 

Evitar cambios en el fichero resolv.conf

A veces el archivo resolv.conf, es modificado al momento de tomar DHCP por una interface, para evitar que pase, siempre como root:

Simple, pero efectivo:
chattr +i /etc/resolv.conf

Si posteriormente necesitamos añadir o modificar alguno de los valores, podremos desbloquearlo simplemente con :
chattr -i /etc/resolv.conf

Saludos,

AmaRo

PPTPd Mikrotik Examples – Remote Access y Site-to-Site

Application Examples

Connecting Remote Client

The following example shows how to connect a computer to a remote office network over PPTP encrypted tunnel giving that computer an IP address from the same network as the remote office has (without need of bridging over EoIP tunnels)

Consider following setup

Pptp-rem-offoce.png

Office router is connected to internet through ether1. Workstations are connected to ether2. Laptop is connected to the internet and can reach Office router’s public IP (in our example it is 192.168.80.1).
First step is to create a user

[admin@RemoteOffice] /ppp secret> add name=Laptop service=pptp password=123
local-address=10.1.101.1 remote-address=10.1.101.100
[admin@RemoteOffice] /ppp secret> print detail
Flags: X - disabled
  0   name="Laptop" service=pptp caller-id="" password="123" profile=default
      local-address=10.1.101.1 remote-address=10.1.101.100 routes==""

[admin@RemoteOffice] /ppp secret>

Notice that pptp local address is the same as routers address on local interface and remote address is form the same range as local network (10.1.101.0/24).

Next step is to enable pptp server and pptp client on the laptop.

[admin@RemoteOffice] /interface pptp-server server> set enabled=yes
[admin@RemoteOffice] /interface pptp-server server> print
            enabled: yes
            max-mtu: 1460
            max-mru: 1460
               mrru: disabled
     authentication: mschap2
  keepalive-timeout: 30
    default-profile: default
[admin@RemoteOffice] /interface pptp-server server>

PPTP client from the laptop should connect to routers public IP which in our example is 192.168.80.1.
Please, consult the respective manual on how to set up a PPTP client with the software You are using.

At this point (when pptp client is successfully connected) if you will try to ping any workstation form the laptop, ping will time out, because Laptop is unable to get ARPs from workstations. Solution is to set up proxy-arp on local interface

[admin@RemoteOffice] /interface ethernet> set Office arp=proxy-arp
[admin@RemoteOffice] /interface ethernet> print
Flags: X - disabled, R - running
  #    NAME                 MTU   MAC-ADDRESS         ARP
  0  R ether1              1500  00:30:4F:0B:7B:C1 enabled
  1  R ether2              1500  00:30:4F:06:62:12 proxy-arp
[admin@RemoteOffice] interface ethernet>

After proxy-arp is enabled client can successfully reach all workstations in local network behind the router.

 

Site-to-Site PPTP

The following is an example of connecting two Intranets using PPTP tunnel over the Internet.

Consider following setup

Site-to-site-pptp-example.png

Office and Home routers are connected to internet through ether1, workstations and laptops are connected to ether2. Both local networks are routed through pptp client, thus they are not in the same broadcast domain. If both networks should be in the same broadcast domain then you need to use BCP and bridge pptp tunnel with local interface.

First step is to create a user

[admin@RemoteOffice] /ppp secret> add name=Home service=pptp password=123
local-address=172.16.1.1 remote-address=172.16.1.2 routes="10.1.202.0/24 172.16.1.2 1"
[admin@RemoteOffice] /ppp secret> print detail
Flags: X - disabled
  0   name="Home" service=pptp caller-id="" password="123" profile=default
      local-address=172.16.1.1 remote-address=172.16.1.2 routes=="10.1.202.0/24 172.16.1.2 1"

[admin@RemoteOffice] /ppp secret>

Notice that we set up pptp to add route whenever client connects. If this option is not set, then you will need static routing configuration on the server to route traffic between sites through pptp tunnel.

Next step is to enable pptp server on the office router and configure pptp client on the Home router.

[admin@RemoteOffice] /interface pptp-server server> set enabled=yes
[admin@RemoteOffice] /interface pptp-server server> print
            enabled: yes
            max-mtu: 1460
            max-mru: 1460
               mrru: disabled
     authentication: mschap2
  keepalive-timeout: 30
    default-profile: default
[admin@RemoteOffice] /interface pptp-server server>
[admin@Home] /interface pptp-client> add user=Home password=123 connect-to=192.168.80.1 disabled=no
[admin@Home] /interface pptp-client> print
Flags: X - disabled, R - running
 0    name="pptp-out1" max-mtu=1460 max-mru=1460 mrru=disabled connect-to=192.168.80.1 user="Home" 
       password="123" profile=default-encryption add-default-route=no dial-on-demand=no 
       allow=pap,chap,mschap1,mschap2
[admin@Home] /interface pptp-client>

Now we need to add route to reach local network behind Home router

[admin@RemoteOffice] /ip route> add dst-address=10.1.101.0/24 gateway=pptp-out1

Now after tunnel is established and routes are set, you should be able to ping remote network.

Fuente: http://wiki.mikrotik.com/wiki/Manual:Interface/PPTP

Saludos- AmaRo